Read the docs
TI-2020-14629 Aliases CVE-2020-23653GHSA-4vp2-mj4m-69m4

An insecure unserialize vulnerability was discovered in ThinkAdmin versions 4.x through…

Priority MEDIUM 49CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

An insecure unserialize vulnerability was discovered in ThinkAdmin versions 4.x through 6.x in app/admin/controller/api/Update.php and app/wechat/controller/api/Push.php, which may lead to arbitrary remote code execution.

Why it matters now

EPSS 0.04276 91st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed zoujingli/thinkadmin (Packagist): 6.1.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—zoujingli/thinkadmin (Packagist)4.0 to before 6.1.06.1.0Patch availableGHSA-4vp2-mj4m-69m4
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • zoujingli/thinkadmin (Packagist) Vendor— Affected 4.0 to before 6.1.0 Fixed in 6.1.0 Patch available GHSA-4vp2-mj4m-69m4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:thinkadmin:thinkadmin:*:*:*:*:*:*:*:*4.0 – 6.0VulnerableThinkadmin
  • cpe:2.3:a:thinkadmin:thinkadmin:*:*:*:*:*:*:*:* Versions 4.0 – 6.0 Vulnerable ·Thinkadmin

Remediation

  • Fix · GHSA-4vp2-mj4m-69m4 zoujingli/thinkadmin (Packagist) Fixed in 6.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-23653
  2. 2026-10-03 Alias added: GHSA-4vp2-mj4m-69m4

References

  • TI-2023-26702 An issue in the component /admin/api.plugs/script of ThinkAdmin v6.1.53 allows attackers… CVSS 3.1HIGH 8.8
  • TI-2020-15591 ThinkAdmin v6 is affected by a directory traversal vulnerability. CVSS 3.1HIGH 7.5
  • TI-2023-17404 An arbitrary file upload vulnerability in the component /api/upload.php of ThinkAdmin v6… CVSS 3.1MEDIUM 6.1
  • TI-2019-08235 application\admin\controller\User.php in ThinkAdmin V4.0 does not prevent continued use… CVSS 3.0CRITICAL 9.8
  • TI-2023-26703 An arbitrary file upload vulnerability in the component /admin/api.upload/file of… CVSS 3.1HIGH 8.8
  • TI-2020-17934 ThinkAdmin v6 has default administrator credentials, which allows attackers to gain… CVSS 3.1HIGH 7.5
See all 8 →

Sources