Document root path disclosure on Maintenance page
Priority LOW 22CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
When in maintenance mode, Magento version 2.4.0 and 2.3.4 (and earlier) are affected by an information disclosure vulnerability that could expose the installation path during build deployments. This information could be helpful to attackers if they are able to identify other exploitable vulnerabilities in the environment.
Why it matters now
EPSS 0.02078 81st percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.3.6, 2.4.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Magento Commerce | up to 2.4.0; up to 2.3.4; up to None | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | before 2.3.6 | 2.3.6 | Patch available | GHSA-mr8q-7f5j-wc79 |
| — | magento/community-edition (Packagist) | 2.4.0 to before 2.4.1 | 2.4.1 | Patch available | GHSA-mr8q-7f5j-wc79 |
- Magento Commerce VendorAdobe Affected up to 2.4.0; up to 2.3.4; up to None Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected before 2.3.6 Fixed in 2.3.6 Patch available GHSA-mr8q-7f5j-wc79
- magento/community-edition (Packagist) Vendor— Affected 2.4.0 to before 2.4.1 Fixed in 2.4.1 Patch available GHSA-mr8q-7f5j-wc79
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* | up to 2.3.4 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | up to 2.3.4 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.4.0:*:*:*:commerce:*:*:* | 2.4.0 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.4.0:*:*:*:open_source:*:*:* | 2.4.0 | Vulnerable | Magento |
- cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions up to 2.3.4 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions up to 2.3.4 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.4.0:*:*:*:commerce:*:*:* Versions 2.4.0 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.4.0:*:*:*:open_source:*:*:* Versions 2.4.0 Vulnerable ·Magento
Remediation
- Fix · GHSA-mr8q-7f5j-wc79 magento/community-edition (Packagist) Fixed in 2.3.6 Advisory →
- Fix · GHSA-mr8q-7f5j-wc79 magento/community-edition (Packagist) Fixed in 2.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-24406
- 2026-10-03 Alias added: GHSA-mr8q-7f5j-wc79
References
More Adobe vulnerabilities
- TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
- TI-2026-35688 ColdFusion | Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22) KEVCVSS 3.1CRITICAL 10.0
- TI-2025-34084 Adobe Experience Manager | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 10.0
- TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
- TI-2023-19615 Analysis CVE-2023-29300 Bypass: Adobe ColdFusion Pre-Auth RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2023-13696 Adobe ColdFusion Deserialization of Untrusted Data Arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-24406 · CVE Program
- CVE-2020-24406 · NVD
- FIRST EPSS
- GHSA-mr8q-7f5j-wc79 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences