Stored XSS in customer address upload feature
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Magento versions 2.4.0 and 2.3.5p1 (and earlier) are affected by a persistent XSS vulnerability that allows users to upload malicious JavaScript via the file upload component. This vulnerability could be abused by an unauthenticated attacker to execute XSS attacks against other Magento users. This vulnerability requires a victim to browse to the uploaded file.
Why it matters now
EPSS 0.01741 77th percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.4.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Magento Commerce | up to 2.4.0; up to 2.3.5p1; up to None | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | before 2.4.1 | 2.4.1 | Patch available | GHSA-jxjc-6xmh-h7mg |
- Magento Commerce VendorAdobe Affected up to 2.4.0; up to 2.3.5p1; up to None Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected before 2.4.1 Fixed in 2.4.1 Patch available GHSA-jxjc-6xmh-h7mg
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* | up to 2.3.4 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | up to 2.3.4 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.5:-:*:*:commerce:*:*:* | 2.3.5 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.5:-:*:*:open_source:*:*:* | 2.3.5 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.5:p1:*:*:commerce:*:*:* | 2.3.5 p1 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.5:p1:*:*:open_source:*:*:* | 2.3.5 p1 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.4.0:*:*:*:commerce:*:*:* | 2.4.0 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.4.0:*:*:*:open_source:*:*:* | 2.4.0 | Vulnerable | Magento |
- cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions up to 2.3.4 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions up to 2.3.4 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.5:-:*:*:commerce:*:*:* Versions 2.3.5 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.5:-:*:*:open_source:*:*:* Versions 2.3.5 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.5:p1:*:*:commerce:*:*:* Versions 2.3.5 p1 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.5:p1:*:*:open_source:*:*:* Versions 2.3.5 p1 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.4.0:*:*:*:commerce:*:*:* Versions 2.4.0 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.4.0:*:*:*:open_source:*:*:* Versions 2.4.0 Vulnerable ·Magento
Remediation
- Fix · GHSA-jxjc-6xmh-h7mg magento/community-edition (Packagist) Fixed in 2.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-24408
- 2026-10-03 Alias added: GHSA-jxjc-6xmh-h7mg
References
More Adobe vulnerabilities
- TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
- TI-2026-35688 ColdFusion | Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22) KEVCVSS 3.1CRITICAL 10.0
- TI-2025-34084 Adobe Experience Manager | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 10.0
- TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
- TI-2023-19615 Analysis CVE-2023-29300 Bypass: Adobe ColdFusion Pre-Auth RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2023-13696 Adobe ColdFusion Deserialization of Untrusted Data Arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-24408 · CVE Program
- CVE-2020-24408 · NVD
- FIRST EPSS
- GHSA-jxjc-6xmh-h7mg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences