An issue was discovered in LemonLDAP::NG through 2.0.8, when NGINX is used.
Priority MEDIUM 47CWE-425Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-425.
Summary
An issue was discovered in LemonLDAP::NG through 2.0.8, when NGINX is used. An attacker may bypass URL-based access control to protected Virtual Hosts by submitting a non-normalized URI. This also affects versions before 0.5.2 of the "Lemonldap::NG handler for Node.js" package.
Why it matters now
EPSS 0.02463 84th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed lemonldap-ng-handler (npm): 0.5.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | lemonldap-ng-handler (npm) | before 0.5.2 | 0.5.2 | Patch available | GHSA-x44x-r84w-8v67 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- lemonldap-ng-handler (npm) Vendor— Affected before 0.5.2 Fixed in 0.5.2 Patch available GHSA-x44x-r84w-8v67
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:lemonldap-ng:lemonldap\:\:ng:*:*:*:*:*:*:*:* | ng | Vulnerable | lemonldap-ng |
| cpe:2.3:a:lemonldap-ng:lemonldap\:\:ng_handler:*:*:*:*:*:node.js:*:* | ng_handler | Vulnerable | lemonldap-ng |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:lemonldap-ng:lemonldap\:\:ng:*:*:*:*:*:*:*:* Versions ng Vulnerable ·lemonldap-ng
- cpe:2.3:a:lemonldap-ng:lemonldap\:\:ng_handler:*:*:*:*:*:node.js:*:* Versions ng_handler Vulnerable ·lemonldap-ng
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-x44x-r84w-8v67 lemonldap-ng-handler (npm) Fixed in 0.5.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-24660
- 2026-10-03 Alias added: GHSA-x44x-r84w-8v67
References
Advisory 4
Sources
- CVE-2020-24660 · CVE Program
- CVE-2020-24660 · NVD
- FIRST EPSS
- GHSA-x44x-r84w-8v67 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences