Read the docs
TI-2020-15644 Aliases CVE-2020-25626GHSA-fx83-3ph3-9j2q

Improper input validation in Django REST Framework

Priority LOW 30CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 2 fixed, 1 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

A flaw was found in Django REST Framework versions before 3.12.0 and before 3.11.2. When using the browseable API viewer, Django REST Framework fails to properly escape certain strings that can come from user input. This allows a user who can control those strings to inject malicious <script> tags, leading to a cross-site-scripting (XSS) vulnerability.

Why it matters now

EPSS 0.01297 70th percentileScored 2026-11-07
Fix Partial djangorestframework (PyPI): 3.11.2Red Hat: 2 advisoriesRed Hat: 2 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Django REST FrameworkAll django-rest-framework versions before 3.12.0 and before 3.11.2—No fix listedCNA
—djangorestframework (PyPI)before 3.11.23.11.2Patch availableGHSA-fx83-3ph3-9j2q
  • Django REST Framework Vendor— Affected All django-rest-framework versions before 3.12.0 and before 3.11.2 Fixed in — No fix listed CNA
  • djangorestframework (PyPI) Vendor— Affected before 3.11.2 Fixed in 3.11.2 Patch available GHSA-fx83-3ph3-9j2q

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:encode:django_rest_framework:*:*:*:*:*:*:*:*before 3.12.0Vulnerableencode
cpe:2.3:a:redhat:ceph_storage:2.0:*:*:*:*:*:*:*2.0VulnerableRed Hat
cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*11.0VulnerableDebian
  • cpe:2.3:a:encode:django_rest_framework:*:*:*:*:*:*:*:* Versions before 3.12.0 Vulnerable ·encode
  • cpe:2.3:a:redhat:ceph_storage:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·Red Hat
  • cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-fx83-3ph3-9j2q djangorestframework (PyPI) Fixed in 3.11.2 Advisory →

Red Hat 2 advisories

  • RHSA-2020:4137 Released 2020-09-30 · Red Hat rating Moderate
    security update - Red Hat Ansible Tower 3.6.6-1 - RHEL7 Container
    • Red Hat Ansible Tower 3.6 for RHEL 7 ansible-tower-36/ansible-tower
  • RHSA-2020:4136 Released 2020-09-30 · Red Hat rating Moderate
    security update - Red Hat Ansible Tower 3.7.3-1 - RHEL7 Container
    • Red Hat Ansible Tower 3.7 for RHEL 7 ansible-tower-37/ansible-tower-rhel7

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Ceph Storage 2AffectedNo fix planned: Out of support scope
Red Hat Ansible Tower 3.6 for RHEL 7Fixed RHSA-2020:4137
Red Hat Ansible Tower 3.7 for RHEL 7Fixed RHSA-2020:4136

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-25626
  2. 2026-10-03 Alias added: GHSA-fx83-3ph3-9j2q

References

Sources