An issue was discovered in the gon gem before gon-6.4.0 for Ruby.
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An issue was discovered in the gon gem before gon-6.4.0 for Ruby. MultiJson does not honor the escape_mode parameter to escape fields as an XSS protection mechanism. To mitigate, json_dumper.rb in gon now does escaping for XSS by default without relying on MultiJson.
Why it matters now
EPSS 0.01376 72nd percentileScored 2026-11-07
Fix Fixed gon (RubyGems): 6.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | gon (RubyGems) | before 6.4.0 | 6.4.0 | Patch available | GHSA-78vq-9j56-wrfr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- gon (RubyGems) Vendor— Affected before 6.4.0 Fixed in 6.4.0 Patch available GHSA-78vq-9j56-wrfr
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gon_project:gon:*:*:*:*:*:ruby:*:* | before 6.4.0 | Vulnerable | Gon Project |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:gon_project:gon:*:*:*:*:*:ruby:*:* Versions before 6.4.0 Vulnerable ·Gon Project
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-78vq-9j56-wrfr gon (RubyGems) Fixed in 6.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-25739
- 2026-10-03 Alias added: GHSA-78vq-9j56-wrfr
References
Advisory 3
Sources
- CVE-2020-25739 · CVE Program
- CVE-2020-25739 · NVD
- FIRST EPSS
- GHSA-78vq-9j56-wrfr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences