Typesetter CMS 5.x through 5.1 allows admins to upload and execute arbitrary PHP code via…
Priority MEDIUM 48CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-434.
Summary
Typesetter CMS 5.x through 5.1 allows admins to upload and execute arbitrary PHP code via a .php file inside a ZIP archive. NOTE: the vendor disputes the significance of this report because "admins are considered trustworthy"; however, the behavior "contradicts our security policy" and is being fixed for 5.2
Why it matters now
EPSS 0.15578 96th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:typesettercms:typesetter:*:*:*:*:*:*:*:* | 5.0 – 5.1 | Vulnerable | Typesetter |
- cpe:2.3:a:typesettercms:typesetter:*:*:*:*:*:*:*:* Versions 5.0 – 5.1 Vulnerable ·Typesetter
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2020-25790
- 2026-10-03 Alias added: GHSA-c7mg-73jx-7c7x
References
More Typesetter vulnerabilities
- TI-2025-43315 Typesetter CMS Reflected XSS via Move Message Handling CVSS 4.0MEDIUM 4.8
- TI-2025-43314 Typesetter CMS Reflected XSS via Status.php CVSS 4.0MEDIUM 4.8
- TI-2018-05032 An issue was discovered in Typesetter 5.1. CVSS 3.0HIGH 8.8
- TI-2022-09152 TypesetterCMS v5.1 was discovered to contain a Cross-Site Request Forgery (CSRF) which is… CVSS 3.1HIGH 8.8
- TI-2018-05031 An issue was discovered in Typesetter 5.1. CVSS 3.0HIGH 8.0
- TI-2020-13638 Cross Site Scriptiong vulnerability in Typesetter 5.1 via the !1) className and !2)… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2020-25790 · CVE Program
- CVE-2020-25790 · NVD
- FIRST EPSS
- GHSA-c7mg-73jx-7c7x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences