In MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4, XSS related to…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
In MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4, XSS related to jQuery can occur. The attacker creates a message with [javascript:payload xss] and turns it into a jQuery object with mw.message().parse(). The expected result is that the jQuery object does not contain an <a> tag (or it does not have a href attribute, or it's empty, etc.). The actual result is that the object contains an <a href ="javascript... that executes when clicked.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mediawiki/core (Packagist) | 1.31.0 to before 1.31.9 | 1.31.9 | Patch available | GHSA-4vr7-m8p8-434h |
| — | mediawiki/core (Packagist) | 1.32.0 to before 1.34.3 | 1.34.3 | Patch available | GHSA-4vr7-m8p8-434h |
| — | mediawiki/core (Packagist) | 1.35.0-rc.0 to before 1.35.0 | 1.35.0 | Patch available | GHSA-4vr7-m8p8-434h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mediawiki/core (Packagist) Vendor— Affected 1.31.0 to before 1.31.9 Fixed in 1.31.9 Patch available GHSA-4vr7-m8p8-434h
- mediawiki/core (Packagist) Vendor— Affected 1.32.0 to before 1.34.3 Fixed in 1.34.3 Patch available GHSA-4vr7-m8p8-434h
- mediawiki/core (Packagist) Vendor— Affected 1.35.0-rc.0 to before 1.35.0 Fixed in 1.35.0 Patch available GHSA-4vr7-m8p8-434h
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* | before 1.31.10; 1.32.0 to before 1.34.4 | Vulnerable | mediawiki |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
- cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions before 1.31.10; 1.32.0 to before 1.34.4 Vulnerable ·mediawiki
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-4vr7-m8p8-434h mediawiki/core (Packagist) Fixed in 1.31.9 Advisory →
- Fix · GHSA-4vr7-m8p8-434h mediawiki/core (Packagist) Fixed in 1.34.3 Advisory →
- Fix · GHSA-4vr7-m8p8-434h mediawiki/core (Packagist) Fixed in 1.35.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 4 | Affected | No fix planned: Out of support scope |
Timeline
- 2026-10-02 Threatist record created from CVE-2020-25814
- 2026-10-03 Alias added: GHSA-4vr7-m8p8-434h
References
Advisory 5
Sources
- CVE-2020-25814 · CVE Program
- CVE-2020-25814 · NVD
- FIRST EPSS
- GHSA-4vr7-m8p8-434h · GitHub Advisory Database · CC BY 4.0
- CVE-2020-25814 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences