HashiCorp Vault and Vault Enterprise versions 1.0 and newer allowed leases created with a…
Priority LOW 32CWE-613Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-613.
Summary
HashiCorp Vault and Vault Enterprise versions 1.0 and newer allowed leases created with a batch token to outlive their TTL because expiration time was not scheduled correctly. Fixed in 1.4.7 and 1.5.4.
Why it matters now
EPSS 0.01012 63rd percentileScored 2026-11-07
Fix Partial github.com/hashicorp/vault (Go): 1.5.4Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/hashicorp/vault (Go) | 1.0.0-beta1 to before 1.5.4 | 1.5.4 | Patch available | GHSA-57gg-cj55-q5g2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/hashicorp/vault (Go) Vendor— Affected 1.0.0-beta1 to before 1.5.4 Fixed in 1.5.4 Patch available GHSA-57gg-cj55-q5g2
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:* | 1.0.0 to before 1.4.7 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* | 1.0.0 to before 1.4.7 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:* | 1.5.0 to before 1.5.4 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* | 1.5.0 to before 1.5.4 | Vulnerable | HashiCorp |
- cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:* Versions 1.0.0 to before 1.4.7 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* Versions 1.0.0 to before 1.4.7 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:* Versions 1.5.0 to before 1.5.4 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* Versions 1.5.0 to before 1.5.4 Vulnerable ·HashiCorp
Remediation
- Fix · GHSA-57gg-cj55-q5g2 github.com/hashicorp/vault (Go) Fixed in 1.5.4 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Openshift Container Storage 4 | Affected | No fix planned: Out of support scope |
Not affected: 2 products
- Red Hat OpenShift Container Platform 4
- Red Hat Openshift Data Foundation 4
Timeline
- 2026-10-02 Threatist record created from CVE-2020-25816
- 2026-10-03 Alias added: GHSA-57gg-cj55-q5g2
References
Advisory 3
More HashiCorp Vault vulnerabilities
- TI-2024-01904 Vault Cert Auth Method Did Not Correctly Validate Non-CA Certificates CVSS 3.1CRITICAL 9.8
- TI-2022-19053 An issue was discovered in HashiCorp Vault and Vault Enterprise before 1.11.3. CVSS 3.1CRITICAL 9.1
- TI-2020-17874 The official vault docker images before 0.11.6 contain a blank password for a root user. CVSS 3.1CRITICAL 9.8
- TI-2020-10142 HashiCorp Vault and Vault Enterprise 1.4.0 and 1.4.1, when configured with the GCP… CVSS 3.1CRITICAL 9.8
- TI-2026-04407 Vault Vulnerable to Server-Side Request Forgery in ACME Challenge Validation via Attacker-Controlled DNS CVSS 3.1HIGH 8.6
- TI-2025-05421 Arbitrary Remote Code Execution via Plugin Catalog Abuse CVSS 3.1CRITICAL 9.1
Sources
- CVE-2020-25816 · CVE Program
- CVE-2020-25816 · NVD
- FIRST EPSS
- GHSA-57gg-cj55-q5g2 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-25816 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences