An issue was discovered in MediaWiki before 1.31.10 and 1.32.x through 1.34.x before…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An issue was discovered in MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4. The non-jqueryMsg version of mw.message().parse() doesn't escape HTML. This affects both message contents (which are generally safe) and the parameters (which can be based on user input). (When jqueryMsg is loaded, it correctly accepts only whitelisted tags in message contents, and escapes all parameters. Situations with an unloaded jqueryMsg are rare in practice, but can for example occur for Special:SpecialPages on a wiki with no extensions installed.)
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mediawiki/core (Packagist) | 1.31.0 to before 1.31.9 | 1.31.9 | Patch available | GHSA-h8qx-mj6v-2934 |
| — | mediawiki/core (Packagist) | 1.32.0 to before 1.34.3 | 1.34.3 | Patch available | GHSA-h8qx-mj6v-2934 |
| — | mediawiki/core (Packagist) | 1.35.0-rc.0 to before 1.35.0 | 1.35.0 | Patch available | GHSA-h8qx-mj6v-2934 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mediawiki/core (Packagist) Vendor— Affected 1.31.0 to before 1.31.9 Fixed in 1.31.9 Patch available GHSA-h8qx-mj6v-2934
- mediawiki/core (Packagist) Vendor— Affected 1.32.0 to before 1.34.3 Fixed in 1.34.3 Patch available GHSA-h8qx-mj6v-2934
- mediawiki/core (Packagist) Vendor— Affected 1.35.0-rc.0 to before 1.35.0 Fixed in 1.35.0 Patch available GHSA-h8qx-mj6v-2934
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* | 1.32.0 to before 1.34.4 | Vulnerable | mediawiki |
| cpe:2.3:a:mediawiki:mediawiki:1.31.10:*:*:*:*:*:*:* | 1.31.10 | Vulnerable | mediawiki |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
- cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions 1.32.0 to before 1.34.4 Vulnerable ·mediawiki
- cpe:2.3:a:mediawiki:mediawiki:1.31.10:*:*:*:*:*:*:* Versions 1.31.10 Vulnerable ·mediawiki
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-h8qx-mj6v-2934 mediawiki/core (Packagist) Fixed in 1.31.9 Advisory →
- Fix · GHSA-h8qx-mj6v-2934 mediawiki/core (Packagist) Fixed in 1.34.3 Advisory →
- Fix · GHSA-h8qx-mj6v-2934 mediawiki/core (Packagist) Fixed in 1.35.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat OpenShift Container Platform 3.11
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2020-25828
- 2026-10-03 Alias added: GHSA-h8qx-mj6v-2934
References
Advisory 5
Sources
- CVE-2020-25828 · CVE Program
- CVE-2020-25828 · NVD
- FIRST EPSS
- GHSA-h8qx-mj6v-2934 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-25828 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences