Remote code execution in dependabot-core
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Dependabot is a set of packages for automated dependency management for Ruby, JavaScript, Python, PHP, Elixir, Rust, Java, .NET, Elm and Go. In Dependabot-Core from version 0.119.0.beta1 before version 0.125.1, there is a remote code execution vulnerability in dependabot-common and dependabot-go_modules when a source branch name contains malicious injectable bash code. For example, if Dependabot is configured to use the following source branch name: "/$({curl,127.0.0.1})", Dependabot will make a HTTP request to the following URL: 127.0.0.1 when cloning the source repository. The fix was applied to version 0.125.1. As a workaround, one can escape the branch name prior to passing it to the Dependabot::Source class.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| dependabot | dependabot-core | before 0.125.1 | 0.125.1 | Patch available | CNA |
| — | dependabot-omnibus (RubyGems) | 0.119.0.beta1 to before 0.125.1 | 0.125.1 | Patch available | GHSA-23f7-99jx-m54r |
| — | dependabot-common (RubyGems) | 0.119.0.beta1 to before 0.125.1 | 0.125.1 | Patch available | GHSA-23f7-99jx-m54r |
- dependabot-core Vendordependabot Affected before 0.125.1 Fixed in 0.125.1 Patch available CNA
- dependabot-omnibus (RubyGems) Vendor— Affected 0.119.0.beta1 to before 0.125.1 Fixed in 0.125.1 Patch available GHSA-23f7-99jx-m54r
- dependabot-common (RubyGems) Vendor— Affected 0.119.0.beta1 to before 0.125.1 Fixed in 0.125.1 Patch available GHSA-23f7-99jx-m54r
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dependabot_project:dependabot:*:*:*:*:*:*:*:* | 0.119.1 to before 0.125.1 | Vulnerable | Dependabot Project |
| cpe:2.3:a:dependabot_project:dependabot:0.119.0:-:*:*:*:*:*:* | 0.119.0 | Vulnerable | Dependabot Project |
| cpe:2.3:a:dependabot_project:dependabot:0.119.0:beta1:*:*:*:*:*:* | 0.119.0 beta1 | Vulnerable | Dependabot Project |
- cpe:2.3:a:dependabot_project:dependabot:*:*:*:*:*:*:*:* Versions 0.119.1 to before 0.125.1 Vulnerable ·Dependabot Project
- cpe:2.3:a:dependabot_project:dependabot:0.119.0:-:*:*:*:*:*:* Versions 0.119.0 Vulnerable ·Dependabot Project
- cpe:2.3:a:dependabot_project:dependabot:0.119.0:beta1:*:*:*:*:*:* Versions 0.119.0 beta1 Vulnerable ·Dependabot Project
Remediation
- Fix · CNA dependabot-core (dependabot) Fixed in 0.125.1
- Fix · GHSA-23f7-99jx-m54r dependabot-omnibus (RubyGems) Fixed in 0.125.1 Advisory →
- Fix · GHSA-23f7-99jx-m54r dependabot-common (RubyGems) Fixed in 0.125.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-26222
- 2026-10-03 Alias added: GHSA-23f7-99jx-m54r
References
Patch 2
Other 5
- https://github.com/dependabot/dependabot-core
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/dependabot-common/CVE-2020-26222.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/dependabot-omnibus/CVE-2020-26222.yml
- https://rubygems.org/gems/dependabot-common
- https://rubygems.org/gems/dependabot-omnibus
Sources
- CVE-2020-26222 · CVE Program
- CVE-2020-26222 · NVD
- FIRST EPSS
- GHSA-23f7-99jx-m54r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences