Blind SQL injection during the CommentGrade process
Priority MEDIUM 50CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Low · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
In the PrestaShop module "productcomments" before version 4.2.1, an attacker can use a Blind SQL injection to retrieve data or stop the MySQL service. The problem is fixed in 4.2.1 of the module.
Why it matters now
EPSS 0.12388 96th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed productcomments (PrestaShop): 4.2.1prestashop/productcomments (Packagist): 4.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PrestaShop | productcomments | 4.0.0 to before 4.2.1 | 4.2.1 | Patch available | CNA |
| — | prestashop/productcomments (Packagist) | 4.0.0 to before 4.2.1 | 4.2.1 | Patch available | GHSA-5v44-7647-xfw9 |
- productcomments VendorPrestaShop Affected 4.0.0 to before 4.2.1 Fixed in 4.2.1 Patch available CNA
- prestashop/productcomments (Packagist) Vendor— Affected 4.0.0 to before 4.2.1 Fixed in 4.2.1 Patch available GHSA-5v44-7647-xfw9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:prestashop:productcomments:*:*:*:*:*:prestashop:*:* | before 4.2.1 | Vulnerable | PrestaShop |
- cpe:2.3:a:prestashop:productcomments:*:*:*:*:*:prestashop:*:* Versions before 4.2.1 Vulnerable ·PrestaShop
Remediation
- Fix · CNA productcomments (PrestaShop) Fixed in 4.2.1
- Fix · GHSA-5v44-7647-xfw9 prestashop/productcomments (Packagist) Fixed in 4.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-26248
- 2026-10-03 Alias added: GHSA-5v44-7647-xfw9
References
Exploit 1
Patch 1
Advisory 4
More PrestaShop Productcomments vulnerabilities
- TI-2022-16360 PrestaShop module Product Comments vulnerable to cross-site scripting (XSS) CVSS 3.1MEDIUM 6.1
Sources
- CVE-2020-26248 · CVE Program
- CVE-2020-26248 · NVD
- FIRST EPSS
- GHSA-5v44-7647-xfw9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences