Read the docs
TI-2020-16074 Aliases CVE-2020-26253GHSA-2ccx-2gf3-8xvv

.dev domains treated as local in Kirby

Priority LOW 31CWE-346Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-346.

Summary

Kirby is a CMS. In Kirby CMS (getkirby/cms) before version 3.3.6, and Kirby Panel before version 2.5.14 there is a vulnerability in which the admin panel may be accessed if hosted on a .dev domain. In order to protect new installations on public servers that don't have an admin account for the Panel yet, we block account registration there by default. This is a security feature, which we implemented years ago in Kirby 2. It helps to avoid that you forget registering your first admin account on a public server. In this case – without our security block – someone else might theoretically be able to find your site, find out it's running on Kirby, find the Panel and then register the account first. It's an unlikely situation, but it's still a certain risk. To be able to register the first Panel account on a public server, you have to enforce the installer via a config setting. This helps to push all users to the best practice of registering your first Panel account on your local machine and upload it together with the rest of the site. This installation block implementation in Kirby versions before 3.3.6 still assumed that .dev domains are local domains, which is no longer true. In the meantime, those domains became publicly available. This means that our installation block is no longer working as expected if you use a .dev domain for your Kirby site. Additionally the local installation check may also fail if your site is behind a reverse proxy. You are only affected if you use a .dev domain or your site is behind a reverse proxy and you have not yet registered your first Panel account on the public server and someone finds your site and tries to login at `yourdomain.dev/panel` before you register your first account. You are not affected if you have already created one or multiple Panel accounts (no matter if on a .dev domain or behind a reverse proxy). The problem has been patched in Kirby 3.3.6. Please upgrade to this or a later version to fix the vulnerability.

Why it matters now

EPSS 0.00568 47th percentileScored 2026-11-07
Fix Fixed kirby (getkirby): 3.3.6getkirby/panel (Packagist): 2.5.14+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
getkirbykirbybefore 3.3.63.3.6Patch availableCNA
—getkirby/panel (Packagist)before 2.5.142.5.14Patch availableGHSA-2ccx-2gf3-8xvv
—getkirby/cms (Packagist)3.0.0 to before 3.3.63.3.6Patch availableGHSA-2ccx-2gf3-8xvv
  • kirby Vendorgetkirby Affected before 3.3.6 Fixed in 3.3.6 Patch available CNA
  • getkirby/panel (Packagist) Vendor— Affected before 2.5.14 Fixed in 2.5.14 Patch available GHSA-2ccx-2gf3-8xvv
  • getkirby/cms (Packagist) Vendor— Affected 3.0.0 to before 3.3.6 Fixed in 3.3.6 Patch available GHSA-2ccx-2gf3-8xvv

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:*before 3.3.6Vulnerablegetkirby
cpe:2.3:a:getkirby:panel:*:*:*:*:*:*:*:*before 2.5.14Vulnerablegetkirby
  • cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:* Versions before 3.3.6 Vulnerable ·getkirby
  • cpe:2.3:a:getkirby:panel:*:*:*:*:*:*:*:* Versions before 2.5.14 Vulnerable ·getkirby

Remediation

  • Fix · CNA kirby (getkirby) Fixed in 3.3.6
  • Fix · GHSA-2ccx-2gf3-8xvv getkirby/panel (Packagist) Fixed in 2.5.14 Advisory →
  • Fix · GHSA-2ccx-2gf3-8xvv getkirby/cms (Packagist) Fixed in 3.3.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-26253
  2. 2026-10-03 Alias added: GHSA-2ccx-2gf3-8xvv

References

  • TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
  • TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
  • TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
  • TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
  • TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
  • TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
See all 40 →

Sources