Cross-site scripting in Gitlab CE/EE
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A XSS vulnerability exists in Gitlab CE/EE from 12.4 before 13.4.7, 13.5 before 13.5.5, and 13.6 before 13.6.2 that allows an attacker to perform cross-site scripting to other users via importing a malicious project
Why it matters now
EPSS 0.00845 58th percentileScored 2026-11-07
Fix Fixed Gitlab CE/EE (GitLab): 13.4.7, 13.5.5, 13.6.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | Gitlab CE/EE | >=12.4; before 13.4.7; >=13.5; before 13.5.5; >=13.6; before 13.6.2 | 13.4.7, 13.5.5, 13.6.2 | Patch available | CNA |
- Gitlab CE/EE VendorGitLab Affected >=12.4; before 13.4.7; >=13.5; before 13.5.5; >=13.6; before 13.6.2 Fixed in 13.4.7, 13.5.5, 13.6.2 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 12.4.0 to before 13.4.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 12.4.0 to before 13.4.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 13.5.0 to before 13.5.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 13.5.0 to before 13.5.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 13.6.0 to before 13.6.2 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 13.6.0 to before 13.6.2 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 12.4.0 to before 13.4.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 12.4.0 to before 13.4.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 13.5.0 to before 13.5.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 13.5.0 to before 13.5.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 13.6.0 to before 13.6.2 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 13.6.0 to before 13.6.2 Vulnerable ·GitLab
Remediation
- Fix · CNA Gitlab CE/EE (GitLab) Fixed in 13.4.7, 13.5.5, 13.6.2
Timeline
- 2026-10-02 Threatist record created from CVE-2020-26407
- 2026-10-03 Alias added: GHSA-79rf-9vhj-jq9w
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2020-26407 · CVE Program
- CVE-2020-26407 · NVD
- FIRST EPSS
- GHSA-79rf-9vhj-jq9w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences