AuthRestServlet in Matrix Synapse before 1.21.0 is vulnerable to XSS due to unsafe…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
AuthRestServlet in Matrix Synapse before 1.21.0 is vulnerable to XSS due to unsafe interpolation of the session GET parameter. This allows a remote attacker to execute an XSS attack on the domain Synapse is hosted on, by supplying the victim user with a malicious URL to the /_matrix/client/r0/auth/*/fallback/web or /_matrix/client/unstable/auth/*/fallback/web Synapse endpoints.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | matrix-synapse (PyPI) | before 1.21.0 | 1.21.0 | Patch available | GHSA-3x8c-fmpc-5rmq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- matrix-synapse (PyPI) Vendor— Affected before 1.21.0 Fixed in 1.21.0 Patch available GHSA-3x8c-fmpc-5rmq
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:matrix:synapse:*:*:*:*:*:*:*:* | before 1.21.0 | Vulnerable | matrix-org |
- cpe:2.3:a:matrix:synapse:*:*:*:*:*:*:*:* Versions before 1.21.0 Vulnerable ·matrix-org
Remediation
- Fix · GHSA-3x8c-fmpc-5rmq matrix-synapse (PyPI) Fixed in 1.21.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-26891
- 2026-10-03 Alias added: GHSA-3x8c-fmpc-5rmq
References
Patch 2
Advisory 3
More matrix-org Synapse vulnerabilities
- TI-2023-15617 Synapse Outgoing federation to specific hosts can be disabled by sending malicious invites CVSS 3.1MEDIUM 5.0
- TI-2024-35327 Synapse allows a a malformed invite to break the invitee's `/sync` CVSS 4.0HIGH 8.7
- TI-2019-13571 Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. CVSS 3.1CRITICAL 9.8
- TI-2024-36056 Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders CVSS 4.0HIGH 8.2
- TI-2024-35318 Synapse allows unsupported content types to lead to memory exhaustion CVSS 4.0HIGH 8.2
- TI-2018-11846 Matrix Synapse before 0.33.3.1 allows remote attackers to spoof events and possibly have… CVSS 3.0HIGH 8.8
Sources
- CVE-2020-26891 · CVE Program
- CVE-2020-26891 · NVD
- FIRST EPSS
- GHSA-3x8c-fmpc-5rmq · GitHub Advisory Database · CC BY 4.0
- CVE-2020-26891 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences