A cross-site scripting (XSS) vulnerability in the Color Dialog plugin for CKEditor 4.15.0…
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A cross-site scripting (XSS) vulnerability in the Color Dialog plugin for CKEditor 4.15.0 allows remote attackers to run arbitrary web script after persuading a user to copy and paste crafted HTML code into one of editor inputs.
Why it matters now
EPSS 0.0205 81st percentileScored 2026-11-07
Fix Fixed ckeditor4 (npm): 4.15.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ckeditor4 (npm) | before 4.15.1 | 4.15.1 | Patch available | GHSA-4m44-5j2g-xf64 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ckeditor4 (npm) Vendor— Affected before 4.15.1 Fixed in 4.15.1 Patch available GHSA-4m44-5j2g-xf64
CPE configurations NVD · 23
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ckeditor:ckeditor:4.15.0:*:*:*:*:*:*:* | 4.15.0 | Vulnerable | ckeditor |
| cpe:2.3:a:oracle:agile_product_lifecycle_management:9.3.5:*:*:*:*:*:*:* | 9.3.5 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:agile_product_lifecycle_management:9.3.6:*:*:*:*:*:*:* | 9.3.6 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:application_express:*:*:*:*:*:*:*:* | before 21.1.0.00.01 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:banking_party_management:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:banking_platform:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:banking_platform:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:banking_platform:2.7.1:*:*:*:*:*:*:* | 2.7.1 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:banking_platform:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:banking_platform:2.9.0:*:*:*:*:*:*:* | 2.9.0 | Vulnerable | Oracle |
- cpe:2.3:a:ckeditor:ckeditor:4.15.0:*:*:*:*:*:*:* Versions 4.15.0 Vulnerable ·ckeditor
- cpe:2.3:a:oracle:agile_product_lifecycle_management:9.3.5:*:*:*:*:*:*:* Versions 9.3.5 Vulnerable ·Oracle
- cpe:2.3:a:oracle:agile_product_lifecycle_management:9.3.6:*:*:*:*:*:*:* Versions 9.3.6 Vulnerable ·Oracle
- cpe:2.3:a:oracle:application_express:*:*:*:*:*:*:*:* Versions before 21.1.0.00.01 Vulnerable ·Oracle
- cpe:2.3:a:oracle:banking_party_management:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:banking_platform:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:banking_platform:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:banking_platform:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Oracle
- cpe:2.3:a:oracle:banking_platform:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:banking_platform:2.9.0:*:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·Oracle
Show 13 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:oracle:commerce_merchandising:11.0.0:*:*:*:*:*:*:* | 11.0.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:commerce_merchandising:11.1.0:*:*:*:*:*:*:* | 11.1.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:commerce_merchandising:11.2.0:*:*:*:*:*:*:* | 11.2.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:commerce_merchandising:11.3.0:*:*:*:*:*:*:* | 11.3.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:commerce_merchandising:11.3.1:*:*:*:*:*:*:* | 11.3.1 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:commerce_merchandising:11.3.2:*:*:*:*:*:*:* | 11.3.2 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:financial_services_analytical_applications_infrastructure:*:*:*:*:*:*:*:* | 8.0.6 – 8.0.9 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:financial_services_analytical_applications_infrastructure:8.1.0:*:*:*:*:*:*:* | 8.1.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:financial_services_analytical_applications_infrastructure:8.1.1:*:*:*:*:*:*:* | 8.1.1 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:jd_edwards_enterpriseone_tools:*:*:*:*:*:*:*:* | before 9.2.6.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.56:*:*:*:*:*:*:* | 8.56 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.57:*:*:*:*:*:*:* | 8.57 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.58:*:*:*:*:*:*:* | 8.58 | Vulnerable | Oracle |
- cpe:2.3:a:oracle:commerce_merchandising:11.0.0:*:*:*:*:*:*:* Versions 11.0.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:commerce_merchandising:11.1.0:*:*:*:*:*:*:* Versions 11.1.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:commerce_merchandising:11.2.0:*:*:*:*:*:*:* Versions 11.2.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:commerce_merchandising:11.3.0:*:*:*:*:*:*:* Versions 11.3.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:commerce_merchandising:11.3.1:*:*:*:*:*:*:* Versions 11.3.1 Vulnerable ·Oracle
- cpe:2.3:a:oracle:commerce_merchandising:11.3.2:*:*:*:*:*:*:* Versions 11.3.2 Vulnerable ·Oracle
- cpe:2.3:a:oracle:financial_services_analytical_applications_infrastructure:*:*:*:*:*:*:*:* Versions 8.0.6 – 8.0.9 Vulnerable ·Oracle
- cpe:2.3:a:oracle:financial_services_analytical_applications_infrastructure:8.1.0:*:*:*:*:*:*:* Versions 8.1.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:financial_services_analytical_applications_infrastructure:8.1.1:*:*:*:*:*:*:* Versions 8.1.1 Vulnerable ·Oracle
- cpe:2.3:a:oracle:jd_edwards_enterpriseone_tools:*:*:*:*:*:*:*:* Versions before 9.2.6.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.56:*:*:*:*:*:*:* Versions 8.56 Vulnerable ·Oracle
- cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.57:*:*:*:*:*:*:* Versions 8.57 Vulnerable ·Oracle
- cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.58:*:*:*:*:*:*:* Versions 8.58 Vulnerable ·Oracle
Remediation
- Fix · GHSA-4m44-5j2g-xf64 ckeditor4 (npm) Fixed in 4.15.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-27193
- 2026-10-03 Alias added: GHSA-4m44-5j2g-xf64
References
Patch 3
Advisory 4
Sources
- CVE-2020-27193 · CVE Program
- CVE-2020-27193 · NVD
- FIRST EPSS
- GHSA-4m44-5j2g-xf64 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences