Read the docs
TI-2020-16630 Aliases CVE-2020-27348GHSA-qxm5-vx5j-pp6w

snapcraft may build snaps with incorrect LD_LIBRARY_PATH

Priority LOW 31CWE-427Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-427.

Summary

In some conditions, a snap package built by snapcraft includes the current directory in LD_LIBRARY_PATH, allowing a malicious snap to gain code execution within the context of another snap if both plug the home interface or similar. This issue affects snapcraft versions prior to 4.4.4, prior to 2.43.1+16.04.1, and prior to 2.43.1+18.04.1.

Why it matters now

EPSS 0.00703 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed snapcraft (Canonical): 4.4.4, 2.43.1+16.04.1snapcraft (PyPI): 4.4.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Canonicalsnapcraft4.4 to before 4.4.4; 2.43.1 to before 2.43.1+16.04.14.4.4, 2.43.1+16.04.1Patch availableCNA
—snapcraft (PyPI)before 4.4.44.4.4Patch availableGHSA-qxm5-vx5j-pp6w
  • snapcraft VendorCanonical Affected 4.4 to before 4.4.4; 2.43.1 to before 2.43.1+16.04.1 Fixed in 4.4.4, 2.43.1+16.04.1 Patch available CNA
  • snapcraft (PyPI) Vendor— Affected before 4.4.4 Fixed in 4.4.4 Patch available GHSA-qxm5-vx5j-pp6w

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:canonical:snapcraft:*:*:*:*:*:*:*:*before 4.4.4VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:*:*:*:*16.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:*:*:*:*18.04VulnerableCanonical
  • cpe:2.3:a:canonical:snapcraft:*:*:*:*:*:*:*:* Versions before 4.4.4 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:*:*:*:* Versions 16.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:*:*:*:* Versions 18.04 Vulnerable ·Canonical

Remediation

  • Fix · CNA snapcraft (Canonical) Fixed in 4.4.4, 2.43.1+16.04.1
  • Fix · GHSA-qxm5-vx5j-pp6w snapcraft (PyPI) Fixed in 4.4.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-27348
  2. 2026-10-03 Alias added: GHSA-qxm5-vx5j-pp6w

References

Sources