Read the docs
TI-2020-16874 Aliases CVE-2020-27792GHSA-7h9w-vh8m-rj5g

Ghostscript: heap buffer over write vulnerability in ghostscript's lp8000_print_page() in gdevlp8k.c

Priority LOW 32CWE-119Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · High
Fix status
Partial Red Hat: 2 fixed, 2 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.

Summary

A heap-based buffer overwrite vulnerability was found in GhostScript's lp8000_print_page() function in the gdevlp8k.c file. This flaw allows an attacker to trick a user into opening a crafted PDF file, triggering the heap buffer overflow that could lead to memory corruption or a denial of service.

Why it matters now

EPSS 0.00468 40th percentileScored 2026-11-07
Fix Partial Red Hat: 1 advisoryRed Hat: 2 fixed, 2 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Red HatRed Hat Enterprise Linux 8—9.27-16.el8_10Patch availableCNA
Red HatRed Hat Enterprise Linux 6——No fix listedCNA
Red HatRed Hat Enterprise Linux 7——No fix listedCNA
Red HatRed Hat Enterprise Linux 9——Not affectedCNA
  • Red Hat Enterprise Linux 8 VendorRed Hat Affected — Fixed in 9.27-16.el8_10 Patch available CNA
  • Red Hat Enterprise Linux 6 VendorRed Hat Affected — Fixed in — No fix listed CNA
  • Red Hat Enterprise Linux 7 VendorRed Hat Affected — Fixed in — No fix listed CNA
  • Red Hat Enterprise Linux 9 VendorRed Hat Affected — Fixed in — Not affected CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:*up to 9.50VulnerableArtifex
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
  • cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:* Versions up to 9.50 Vulnerable ·Artifex
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian

Remediation

Red Hat 1 advisory

  • RHSA-2025:4362 Released 2025-04-30 · Red Hat rating Moderate
    ghostscript security update
    • Red Hat Enterprise Linux AppStream (v. 8) ghostscript-9.27-16.el8_10, ghostscript-x11-9.27-16.el8_10, libgs-9.27-16.el8_10
    • Red Hat Enterprise Linux CRB (v. 8) ghostscript-doc-9.27-16.el8_10, ghostscript-tools-dvipdf-9.27-16.el8_10, ghostscript-tools-fonts-9.27-16.el8_10 +2

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 7AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2025:4362
Red Hat Enterprise Linux CRB (v. 8)Fixed RHSA-2025:4362
Not affected: 1 product
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-27792
  2. 2026-10-03 Alias added: GHSA-7h9w-vh8m-rj5g

References

  • TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
  • TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
See all 7413 →

Sources