Read the docs
TI-2020-17281 Aliases CVE-2020-28468GHSA-7xc5-ggpp-g249

Improper Control of Generation of Code ('Code Injection')

Priority MEDIUM 49CWE-74Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

This affects the package pwntools before 4.3.1. The shellcraft generator for affected versions of this module are vulnerable to Server-Side Template Injection (SSTI), which can lead to remote code execution.

Why it matters now

EPSS 0.04379 91st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed pwntools: 4.3.1pwntools (PyPI): 4.3.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—pwntoolsbefore 4.3.14.3.1Patch availableCNA
—pwntools (PyPI)before 4.3.14.3.1Patch availableGHSA-7xc5-ggpp-g249
  • pwntools Vendor— Affected before 4.3.1 Fixed in 4.3.1 Patch available CNA
  • pwntools (PyPI) Vendor— Affected before 4.3.1 Fixed in 4.3.1 Patch available GHSA-7xc5-ggpp-g249

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pwntools_project:pwntools:*:*:*:*:*:*:*:*before 4.3.1VulnerablePwntools Project
  • cpe:2.3:a:pwntools_project:pwntools:*:*:*:*:*:*:*:* Versions before 4.3.1 Vulnerable ·Pwntools Project

Remediation

  • Fix · CNA pwntools Fixed in 4.3.1
  • Fix · GHSA-7xc5-ggpp-g249 pwntools (PyPI) Fixed in 4.3.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-28468
  2. 2026-10-03 Alias added: GHSA-7xc5-ggpp-g249

References

Sources