Insecure Defaults
Priority LOW 25CWE-346Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-346.
Summary
The package socket.io before 2.4.0 are vulnerable to Insecure Defaults due to CORS Misconfiguration. All domains are whitelisted by default.
Why it matters now
EPSS 0.00745 55th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed socket.io: 2.4.0socket.io (npm): 2.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | socket.io | before 2.4.0 | 2.4.0 | Patch available | CNA |
| — | socket.io (npm) | before 2.4.0 | 2.4.0 | Patch available | GHSA-fxwf-4rqh-v8g3 |
- socket.io Vendor— Affected before 2.4.0 Fixed in 2.4.0 Patch available CNA
- socket.io (npm) Vendor— Affected before 2.4.0 Fixed in 2.4.0 Patch available GHSA-fxwf-4rqh-v8g3
Remediation
- Fix · CNA socket.io Fixed in 2.4.0
- Fix · GHSA-fxwf-4rqh-v8g3 socket.io (npm) Fixed in 2.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-28481
- 2026-10-03 Alias added: GHSA-fxwf-4rqh-v8g3
References
More socketio Socket.io vulnerabilities
- TI-2017-11755 Socket.io is a realtime application framework that provides communication via websockets. CVSS 3.0HIGH 7.5
Sources
- CVE-2020-28481 · CVE Program
- CVE-2020-28481 · NVD
- FIRST EPSS
- GHSA-fxwf-4rqh-v8g3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences