Cross Site Scripting (XSS) vulnerability in xCss Valine v1.4.14 via the nick parameter to /classes/Comment.
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross Site Scripting (XSS) vulnerability in xCss Valine v1.4.14 via the nick parameter to /classes/Comment.
Why it matters now
EPSS 0.00472 41st percentileScored 2026-11-07
Fix Fixed valine (npm): 1.4.15
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | valine (npm) | before 1.4.15 | 1.4.15 | Patch available | GHSA-6xvq-2gj8-4276 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- valine (npm) Vendor— Affected before 1.4.15 Fixed in 1.4.15 Patch available GHSA-6xvq-2gj8-4276
Remediation
- Fix · GHSA-6xvq-2gj8-4276 valine (npm) Fixed in 1.4.15 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-28847
- 2026-10-03 Alias added: GHSA-6xvq-2gj8-4276
References
More Valine.js Valine vulnerabilities
- TI-2022-18133 Valine v1.4.18 was discovered to contain a remote code execution (RCE) vulnerability… CVSS 3.1CRITICAL 9.6
- TI-2018-13676 An issue was discovered in Valine v1.3.3. CVSS 3.1MEDIUM 6.1
- TI-2021-13797 Valine 1.4.14 allows remote attackers to cause a denial of service (application outage)… CVSS 3.1MEDIUM 5.3
Sources
- CVE-2020-28847 · CVE Program
- CVE-2020-28847 · NVD
- FIRST EPSS
- GHSA-6xvq-2gj8-4276 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences