Multiple cross-site scripting (XSS) vulnerabilities in Papermerge before 1.5.2 allow…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in Papermerge before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the rename, tag, upload, or create folder function. The payload can be in a folder, a tag, or a document's filename. If email consumption is configured in Papermerge, a malicious document can be sent by email and is automatically uploaded into the Papermerge web application. Therefore, no authentication is required to exploit XSS if email consumption is configured. Otherwise authentication is required.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | papermerge (PyPI) | 1.2.0 to before 1.5.2 | 1.5.2 | Patch available | GHSA-9w49-m7xh-5r39 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- papermerge (PyPI) Vendor— Affected 1.2.0 to before 1.5.2 Fixed in 1.5.2 Patch available GHSA-9w49-m7xh-5r39
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:papermerge:papermerge:*:*:*:*:*:*:*:* | before 1.5.2 | Vulnerable | papermerge |
- cpe:2.3:a:papermerge:papermerge:*:*:*:*:*:*:*:* Versions before 1.5.2 Vulnerable ·papermerge
Remediation
- Fix · GHSA-9w49-m7xh-5r39 papermerge (PyPI) Fixed in 1.5.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-29456
- 2026-10-03 Alias added: GHSA-9w49-m7xh-5r39
References
Advisory 4
Sources
- CVE-2020-29456 · CVE Program
- CVE-2020-29456 · NVD
- FIRST EPSS
- GHSA-9w49-m7xh-5r39 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences