Read the docs
TI-2020-17866 Aliases CVE-2020-35177GHSA-rpgp-9hmg-j25x

HashiCorp Vault and Vault Enterprise 1.4.1 and newer allowed the enumeration of users via…

Priority LOW 27CWE-209Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-209.

Summary

HashiCorp Vault and Vault Enterprise 1.4.1 and newer allowed the enumeration of users via the LDAP auth method. Fixed in 1.5.6 and 1.6.1.

Why it matters now

EPSS 0.01305 70th percentileScored 2026-11-07
Fix Fixed github.com/hashicorp/vault (Go): 1.5.6, 1.6.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—github.com/hashicorp/vault (Go)1.5.0 to before 1.5.61.5.6Patch availableGHSA-rpgp-9hmg-j25x
—github.com/hashicorp/vault (Go)1.6.0 to before 1.6.11.6.1Patch availableGHSA-rpgp-9hmg-j25x
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • github.com/hashicorp/vault (Go) Vendor— Affected 1.5.0 to before 1.5.6 Fixed in 1.5.6 Patch available GHSA-rpgp-9hmg-j25x
  • github.com/hashicorp/vault (Go) Vendor— Affected 1.6.0 to before 1.6.1 Fixed in 1.6.1 Patch available GHSA-rpgp-9hmg-j25x

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:*1.5.0 to before 1.5.6VulnerableHashiCorp
cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:*1.5.0 to before 1.5.6VulnerableHashiCorp
cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:*1.6.0 to before 1.6.1VulnerableHashiCorp
cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:*1.6.0 to before 1.6.1VulnerableHashiCorp
  • cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:* Versions 1.5.0 to before 1.5.6 Vulnerable ·HashiCorp
  • cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* Versions 1.5.0 to before 1.5.6 Vulnerable ·HashiCorp
  • cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:* Versions 1.6.0 to before 1.6.1 Vulnerable ·HashiCorp
  • cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* Versions 1.6.0 to before 1.6.1 Vulnerable ·HashiCorp

Remediation

  • Fix · GHSA-rpgp-9hmg-j25x github.com/hashicorp/vault (Go) Fixed in 1.5.6 Advisory →
  • Fix · GHSA-rpgp-9hmg-j25x github.com/hashicorp/vault (Go) Fixed in 1.6.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

Not affected: 7 products
  • Logging Subsystem for Red Hat OpenShift
  • OpenShift Service Mesh 1
  • OpenShift Service Mesh 2.0
  • Red Hat Advanced Cluster Management for Kubernetes 2
  • Red Hat OpenShift Container Platform 4
  • Red Hat Openshift Container Storage 4
  • Red Hat Openshift Data Foundation 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-35177
  2. 2026-10-03 Alias added: GHSA-rpgp-9hmg-j25x

References

  • TI-2024-01904 Vault Cert Auth Method Did Not Correctly Validate Non-CA Certificates CVSS 3.1CRITICAL 9.8
  • TI-2022-19053 An issue was discovered in HashiCorp Vault and Vault Enterprise before 1.11.3. CVSS 3.1CRITICAL 9.1
  • TI-2020-17874 The official vault docker images before 0.11.6 contain a blank password for a root user. CVSS 3.1CRITICAL 9.8
  • TI-2020-10142 HashiCorp Vault and Vault Enterprise 1.4.0 and 1.4.1, when configured with the GCP… CVSS 3.1CRITICAL 9.8
  • TI-2026-04407 Vault Vulnerable to Server-Side Request Forgery in ACME Challenge Validation via Attacker-Controlled DNS CVSS 3.1HIGH 8.6
  • TI-2025-05421 Arbitrary Remote Code Execution via Plugin Catalog Abuse CVSS 3.1CRITICAL 9.1
See all 71 →

Sources