jsonparser 1.0.0 allows attackers to cause a denial of service (panic: runtime error…
Priority LOW 37CWE-125Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-125 and the CVSS impact.
Summary
jsonparser 1.0.0 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a GET call.
Why it matters now
EPSS 0.02308 83rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial github.com/buger/jsonparser (Go): 1.1.1Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/buger/jsonparser (Go) | before 1.1.1 | 1.1.1 | Patch available | GHSA-8vrw-m3j9-j27c |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/buger/jsonparser (Go) Vendor— Affected before 1.1.1 Fixed in 1.1.1 Patch available GHSA-8vrw-m3j9-j27c
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jsonparser_project:jsonparser:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | Jsonparser Project |
| cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* | 32 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
- cpe:2.3:a:jsonparser_project:jsonparser:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Jsonparser Project
- cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-8vrw-m3j9-j27c github.com/buger/jsonparser (Go) Fixed in 1.1.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Advanced Cluster Management for Kubernetes 2 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2020-35381
- 2026-10-03 Alias added: GHSA-8vrw-m3j9-j27c
References
Advisory 3
Other 6
- https://github.com/buger/jsonparser/pull/221
- https://github.com/buger/jsonparser/commit/df3ea76ece10095374fd1c9a22a4fb85a44efc42
- https://github.com/buger/jsonparser
- https://lists.fedoraproject.org/archives/list/[email protected]/message/27EA7OGCELV7QFAGVIHODHWKMKGFVIUZ
- https://lists.fedoraproject.org/archives/list/[email protected]/message/LJO5N7YTDEUSTKYTNA372CE6VHCZJWUG
- https://pkg.go.dev/vuln/GO-2021-0057
Sources
- CVE-2020-35381 · CVE Program
- CVE-2020-35381 · NVD
- FIRST EPSS
- GHSA-8vrw-m3j9-j27c · GitHub Advisory Database · CC BY 4.0
- CVE-2020-35381 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences