JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe…
Priority MEDIUM 47CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe deserialization that can result in code execution via crafted StreamMessage data.
Why it matters now
EPSS 0.02844 86th percentileScored 2026-11-07
Fix Fixed com.rabbitmq.jms:rabbitmq-jms (Maven): 2.2.0, 1.15.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | com.rabbitmq.jms:rabbitmq-jms (Maven) | 2.0 to before 2.2.0 | 2.2.0 | Patch available | GHSA-v525-c3g5-cg9p |
| — | com.rabbitmq.jms:rabbitmq-jms (Maven) | 1.0 to before 1.15.2 | 1.15.2 | Patch available | GHSA-v525-c3g5-cg9p |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- com.rabbitmq.jms:rabbitmq-jms (Maven) Vendor— Affected 2.0 to before 2.2.0 Fixed in 2.2.0 Patch available GHSA-v525-c3g5-cg9p
- com.rabbitmq.jms:rabbitmq-jms (Maven) Vendor— Affected 1.0 to before 1.15.2 Fixed in 1.15.2 Patch available GHSA-v525-c3g5-cg9p
Remediation
- Fix · GHSA-v525-c3g5-cg9p com.rabbitmq.jms:rabbitmq-jms (Maven) Fixed in 2.2.0 Advisory →
- Fix · GHSA-v525-c3g5-cg9p com.rabbitmq.jms:rabbitmq-jms (Maven) Fixed in 1.15.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36282
- 2026-10-03 Alias added: GHSA-v525-c3g5-cg9p
References
Advisory 3
Sources
- CVE-2020-36282 · CVE Program
- CVE-2020-36282 · NVD
- FIRST EPSS
- GHSA-v525-c3g5-cg9p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences