jamesmartin Inline SVG URL Parameter helpers.rb cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability has been found in jamesmartin Inline SVG up to 1.7.1 and classified as problematic. Affected by this vulnerability is an unknown functionality of the file lib/inline_svg/action_view/helpers.rb of the component URL Parameter Handler. The manipulation of the argument filename leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.7.2 is able to address this issue. The identifier of the patch is f5363b351508486021f99e083c92068cf2943621. It is recommended to upgrade the affected component. The identifier VDB-217597 was assigned to this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jamesmartin | Inline SVG | 1.7.0; 1.7.1 | — | No fix listed | CNA |
| — | inline_svg (RubyGems) | before 1.7.2 | 1.7.2 | Patch available | GHSA-p33q-4h4m-j994 |
- Inline SVG Vendorjamesmartin Affected 1.7.0; 1.7.1 Fixed in — No fix listed CNA
- inline_svg (RubyGems) Vendor— Affected before 1.7.2 Fixed in 1.7.2 Patch available GHSA-p33q-4h4m-j994
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:inline_svg_project:inline_svg:*:*:*:*:*:*:*:* | before 1.7.2 | Vulnerable | Inline Svg Project |
- cpe:2.3:a:inline_svg_project:inline_svg:*:*:*:*:*:*:*:* Versions before 1.7.2 Vulnerable ·Inline Svg Project
Remediation
- Fix · GHSA-p33q-4h4m-j994 inline_svg (RubyGems) Fixed in 1.7.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36644
- 2026-10-03 Alias added: GHSA-p33q-4h4m-j994
References
Patch 3
Sources
- CVE-2020-36644 · CVE Program
- CVE-2020-36644 · NVD
- FIRST EPSS
- GHSA-p33q-4h4m-j994 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences