Yii Yii2 Gii before 2.2.2 allows remote attackers to execute arbitrary code via the…
Priority HIGH 73CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Yii Yii2 Gii before 2.2.2 allows remote attackers to execute arbitrary code via the Generator.php messageCategory field. The attacker can embed arbitrary PHP code into the model file.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01524 74th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed yiisoft/yii2-gii (Packagist): 2.2.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | yiisoft/yii2-gii (Packagist) | before 2.2.2 | 2.2.2 | Patch available | GHSA-3mpg-q26j-83j5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- yiisoft/yii2-gii (Packagist) Vendor— Affected before 2.2.2 Fixed in 2.2.2 Patch available GHSA-3mpg-q26j-83j5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yiiframework:gii:*:*:*:*:*:yii2:*:* | before 2.2.2 | Vulnerable | Yiiframework |
- cpe:2.3:a:yiiframework:gii:*:*:*:*:*:yii2:*:* Versions before 2.2.2 Vulnerable ·Yiiframework
Remediation
- Fix · GHSA-3mpg-q26j-83j5 yiisoft/yii2-gii (Packagist) Fixed in 2.2.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36655
- 2026-10-03 Alias added: GHSA-3mpg-q26j-83j5
References
Exploit 2
More Yiiframework Gii vulnerabilities
- TI-2022-15209 Yii Yii2 Gii through 2.2.4 allows stored XSS by injecting a payload into any field. CVSS 3.1MEDIUM 5.4
Sources
- CVE-2020-36655 · CVE Program
- CVE-2020-36655 · NVD
- FIRST EPSS
- GHSA-3mpg-q26j-83j5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences