Simple:Press – WordPress Forum Plugin <= 6.6.0 - Arbitrary File Upload
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.
Summary
The Simple:Press – WordPress Forum Plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the ~/admin/resources/jscript/ajaxupload/sf-uploader.php file in versions up to, and including, 6.6.0. This makes it possible for attackers to upload arbitrary files on the affected sites server which may make remote code execution possible.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| simplepress | Simple:Press Forum | before 6.6.1 | 6.6.1 | Patch available | CNA |
- Simple:Press Forum Vendorsimplepress Affected before 6.6.1 Fixed in 6.6.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simple-press:simple\:press:*:*:*:*:*:wordpress:*:* | press | Vulnerable | Simple-press |
- cpe:2.3:a:simple-press:simple\:press:*:*:*:*:*:wordpress:*:* Versions press Vulnerable ·Simple-press
Remediation
- Fix · CNA Simple:Press Forum (simplepress) Fixed in 6.6.1
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36706
- 2026-10-03 Alias added: GHSA-fp5c-vf9m-6gv3
References
Advisory 3
More simplepress vulnerabilities
- TI-2024-09711 SimplePress Forum < 6.10.11 - Reflected XSS CVSS 3.1HIGH 7.1
- TI-2022-03698 Simple:Press <= 6.8 - Authenticated (Subscriber+) Path Traversal to Arbitrary File Deletion CVSS 3.1HIGH 8.1
- TI-2022-03695 Simple:Press <= 6.8 - Unauthenticated Stored Cross-Site Scripting via Forum Replies CVSS 3.1HIGH 7.2
- TI-2025-22567 WordPress Simple:Press plugin <= 6.11.5 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
- TI-2022-03696 Simple:Press <= 6.8 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Profile Signatures CVSS 3.1MEDIUM 6.4
- TI-2024-11513 Simple:Press Forum <= 6.10.11 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2020-36706 · CVE Program
- CVE-2020-36706 · NVD
- FIRST EPSS
- GHSA-fp5c-vf9m-6gv3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences