Page Builder: KingComposer < 2.9.4 - Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Page Builder: KingComposer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via via shortcode in versions before 2.9.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| King-Theme | Page Builder: KingComposer – Free Drag and Drop page builder by King-Theme | before 2.9.4 | 2.9.4 | Patch available | CNA |
- Page Builder: KingComposer – Free Drag and Drop page builder by King-Theme VendorKing-Theme Affected before 2.9.4 Fixed in 2.9.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:king-theme:page_builder_kingcomposer:*:*:*:*:*:wordpress:*:* | before 2.9.4 | Vulnerable | King-Theme |
- cpe:2.3:a:king-theme:page_builder_kingcomposer:*:*:*:*:*:wordpress:*:* Versions before 2.9.4 Vulnerable ·King-Theme
Remediation
- Fix · CNA Page Builder: KingComposer – Free Drag and Drop page builder by King-Theme (kingthemes) Fixed in 2.9.4
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36709
- 2026-10-03 Alias added: GHSA-pr9r-mj5f-cvxc
- 2026-10-21 EPSS moved to the 50th–90th percentile
References
More King-Theme Page Builder Kingcomposer vulnerabilities
- TI-2020-18871 Page Builder: KingComposer < 2.9.4 - Authorization Bypass due to Improper Access Control CVSS 3.1HIGH 8.8
Sources
- CVE-2020-36709 · CVE Program
- CVE-2020-36709 · NVD
- FIRST EPSS
- GHSA-pr9r-mj5f-cvxc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences