Kali Forms <= 2.1.1 - Missing Authorization to Settings Update
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Kali Forms plugin for WordPress is vulnerable to Authenticated Options Change in versions up to, and including, 2.1.1. This is due to the update_option lacking proper authentication checks. This makes it possible for any authenticated attacker to change (or delete) the plugin's settings.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Kali Forms — Contact Form & Drag-and-Drop Builder (wpchill) Fixed in 2.1.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
wpchill Kali Forms — Contact Form & Drag-and-Drop Builder 2.1.2
3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2020-18883 Kali Forms <= 2.1.1 - Unauthenticated Arbitrary Post DeletionPriority MEDIUM 45
- TI-2020-18888 Kali Forms <= 2.1.1 - Cross-Site Request ForgeryPriority MEDIUM 41
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36720
- 2026-10-03 Alias added: GHSA-qpfj-j74j-7qq6
References
More wpchill vulnerabilities
- TI-2020-18879 Epsilon Framework Themes (Various Versions) - Function Injection CVSS 3.1CRITICAL 9.8
- TI-2021-07068 Download Monitor < 4.4.5 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2022-22320 WordPress Download Monitor Plugin <= 4.7.60 is vulnerable to Sensitive Data Exposure CVSS 3.1HIGH 7.5
- TI-2024-03458 Image Photo Gallery Final Tiles Grid < 3.6.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.8
- TI-2021-05950 WordPress Download Monitor plugin <= 4.4.6 - Auth. Stored Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 4.8
- TI-2026-03090 Kali Forms <= 2.4.9 - Unauthenticated Remote Code Execution via form_process CVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-36720 · CVE Program
- CVE-2020-36720 · NVD
- FIRST EPSS
- GHSA-qpfj-j74j-7qq6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences