Read the docs
TI-2020-18902 Aliases CVE-2020-36731GHSA-x5rc-5886-54gw

Flexible Checkout Fields for WooCommerce <= 2.3.1 - Unauthenticated Arbitrary Plugin Settings Update

Priority MEDIUM 40CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The Flexible Checkout Fields for WooCommerce plugin for WordPress is vulnerable to Unauthenticated Arbitrary Plugin Settings update, in addition to Stored Cross-Site Scripting in versions up to, and including, 2.3.1. This is due to missing authorization checks on the updateSettingsAction() function which is called via an admin_init hook, along with missing sanitization and escaping on the settings that are stored.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01342 71st percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Flexible Checkout Fields for WooCommerce – WooCommerce Checkout Manager (wpdesk): 2.3.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
wpdeskFlexible Checkout Fields for WooCommerce – WooCommerce Checkout Managerbefore 2.3.22.3.2Patch availableCNA
  • Flexible Checkout Fields for WooCommerce – WooCommerce Checkout Manager Vendorwpdesk Affected before 2.3.2 Fixed in 2.3.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpdesk:flexible_checkout_fields:*:*:*:*:free:wordpress:*:*up to 2.3.1Vulnerablewpdesk
  • cpe:2.3:a:wpdesk:flexible_checkout_fields:*:*:*:*:free:wordpress:*:* Versions up to 2.3.1 Vulnerable ·wpdesk

Remediation

  • Fix · CNA Flexible Checkout Fields for WooCommerce – WooCommerce Checkout Manager (wpdesk) Fixed in 2.3.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-36731
  2. 2026-10-03 Alias added: GHSA-x5rc-5886-54gw

References

  • TI-2024-20643 WordPress Flexible Checkout Fields for WooCommerce plugin <= 4.1.2 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8

Sources