Import / Export Customizer Settings <= 1.0.3 - Cross-Site Request Forgery Bypass
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The Import / Export Customizer Settings plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.0.3. This is due to missing or incorrect nonce validation on the astra_admin_errors() function. This makes it possible for unauthenticated attackers to display an import status via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Brainstorm Force | Import / Export Customizer Settings | before 1.0.4 | 1.0.4 | Patch available | CNA |
- Import / Export Customizer Settings VendorBrainstorm Force Affected before 1.0.4 Fixed in 1.0.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:brainstormforce:import_\/_export_customizer_settings:*:*:*:*:*:wordpress:*:* | up to 1.0.3 | Vulnerable | Brainstorm Force |
- cpe:2.3:a:brainstormforce:import_\/_export_customizer_settings:*:*:*:*:*:wordpress:*:* Versions up to 1.0.3 Vulnerable ·Brainstorm Force
Remediation
- Fix · CNA Import / Export Customizer Settings (brainstormforce) Fixed in 1.0.4
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36737
- 2026-10-03 Alias added: GHSA-c948-28m2-x4q8
References
Other 7
- https://blog.nintechnet.com/25-wordpress-plugins-vulnerable-to-csrf-attacks/
- https://blog.nintechnet.com/more-wordpress-plugins-and-themes-vulnerable-to-csrf-attacks/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-3/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-2/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-1/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-5/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-4/
Sources
- CVE-2020-36737 · CVE Program
- CVE-2020-36737 · NVD
- FIRST EPSS
- GHSA-c948-28m2-x4q8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences