MultiVendorX – MultiVendor Marketplace Solution For WooCommerce <= 3.5.7 - Cross-Site Request Forgery Bypass
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The MultiVendorX plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.5.7. This is due to missing or incorrect nonce validation on the submit_comment() function. This makes it possible for unauthenticated attackers to submit comments via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MultiVendorX | MultiVendorX – WooCommerce Multivendor Marketplace Solutions | before 3.5.8 | 3.5.8 | Patch available | CNA |
- MultiVendorX – WooCommerce Multivendor Marketplace Solutions VendorMultiVendorX Affected before 3.5.8 Fixed in 3.5.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:multivendorx:multivendorx:*:*:*:*:*:wordpress:*:* | up to 3.5.7 | Vulnerable | MultiVendorX |
- cpe:2.3:a:multivendorx:multivendorx:*:*:*:*:*:wordpress:*:* Versions up to 3.5.7 Vulnerable ·MultiVendorX
Remediation
- Fix · CNA MultiVendorX – WooCommerce Multivendor Marketplace Solutions (wcmp) Fixed in 3.5.8
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36741
- 2026-10-03 Alias added: GHSA-4hmj-qm7w-ccv8
References
Advisory 8
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2c3d9fa7-8ea2-4213-8b28-2ca9191a8223?source=cve
- https://blog.nintechnet.com/25-wordpress-plugins-vulnerable-to-csrf-attacks/
- https://blog.nintechnet.com/more-wordpress-plugins-and-themes-vulnerable-to-csrf-attacks/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-3/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-2/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-1/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-5/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-4/
More Multivendorx vulnerabilities
- TI-2025-00410 Path traversal in MultiVendorX – WooCommerce Multivendor Marketplace Solutions CVSS 3.1CRITICAL 9.8
- TI-2024-07685 Missing authorization in MultiVendorX – WooCommerce Multivendor Marketplace Solutions CVSS 3.1CRITICAL 9.8
- TI-2025-30587 WordPress MultiVendorX plugin <= 4.2.22 - Sensitive Data Exposure Vulnerability CVSS 3.1HIGH 7.5
- TI-2024-20680 WordPress MultiVendorX Marketplace <= 4.1.3 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2025-02437 Missing authorization in MultiVendorX – WooCommerce Multivendor Marketplace Solutions CVSS 3.1MEDIUM 6.5
- TI-2025-30589 WordPress MultiVendorX plugin <= 4.2.22 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2020-36741 · CVE Program
- CVE-2020-36741 · NVD
- FIRST EPSS
- GHSA-4hmj-qm7w-ccv8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences