Dokan <= 3.0.8 - Cross-Site Request Forgery Bypass
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The Dokan plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.0.8. This is due to missing or incorrect nonce validation on the handle_order_export() function. This makes it possible for unauthenticated attackers to trigger an order export via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| dokaninc | Dokan: AI Powered WooCommerce Multivendor Marketplace Solution – Build Your Own Amazon, eBay, Etsy | before 3.0.9 | 3.0.9 | Patch available | CNA |
- Dokan: AI Powered WooCommerce Multivendor Marketplace Solution – Build Your Own Amazon, eBay, Etsy Vendordokaninc Affected before 3.0.9 Fixed in 3.0.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dokan:dokan:*:*:*:*:lite:wordpress:*:* | before 3.0.9 | Vulnerable | Dokan, Inc. |
- cpe:2.3:a:dokan:dokan:*:*:*:*:lite:wordpress:*:* Versions before 3.0.9 Vulnerable ·Dokan, Inc.
Remediation
- Fix · CNA Dokan: AI Powered WooCommerce Multivendor Marketplace Solution – Build Your Own Amazon, eBay, Etsy (dokaninc) Fixed in 3.0.9
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36748
- 2026-10-03 Alias added: GHSA-wxjf-25cc-8vg7
References
Other 6
- https://blog.nintechnet.com/more-wordpress-plugins-and-themes-vulnerable-to-csrf-attacks/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-3/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-2/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-1/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-5/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-4/
More dokaninc vulnerabilities
- TI-2026-07700 Dokan <= 5.0.2 - Missing Authorization to Authenticated (Vendor+) Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2025-13661 Improper access control in dokaninc Dokan: AI Powered WooCommerce Multivendor Marketplace… CVSS 3.1HIGH 8.1
- TI-2026-03019 Information disclosure in dokaninc Dokan: AI Powered WooCommerce Multivendor Marketplace… CVSS 3.1MEDIUM 5.3
- TI-2026-10170 Cross-site scripting in dokaninc Dokan: AI Powered WooCommerce Multivendor Marketplace… CVSS 3.1MEDIUM 6.4
- TI-2026-10330 Authorization bypass in dokaninc Dokan: AI Powered WooCommerce Multivendor Marketplace… CVSS 3.1MEDIUM 4.3
- TI-2026-08784 Authorization bypass in dokaninc Dokan: AI Powered WooCommerce Multivendor Marketplace… CVSS 3.1MEDIUM 4.3
Sources
- CVE-2020-36748 · CVE Program
- CVE-2020-36748 · NVD
- FIRST EPSS
- GHSA-wxjf-25cc-8vg7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences