Read the docs
TI-2020-18930 Aliases CVE-2020-36761GHSA-2xcx-834w-fp84

Top 10 <= 2.9.4 - Cross-Site Request Forgery Bypass

Priority LOW 21CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.

Summary

The Top 10 plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.10.4. This is due to missing or incorrect nonce validation on the tptn_export_tables() function. This makes it possible for unauthenticated attackers to generate an export of the top 10 table via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00563 47th percentileScored 2026-11-07
Public exploit Yes 8 exploit referencesTagged by NVD
Fix Fixed WebberZone Top 10 — Popular Posts (ajay): 2.9.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ajayWebberZone Top 10 — Popular Postsbefore 2.9.52.9.5Patch availableCNA
  • WebberZone Top 10 — Popular Posts Vendorajay Affected before 2.9.5 Fixed in 2.9.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:webberzone:top_10:*:*:*:*:*:wordpress:*:*up to 2.9.4Vulnerableajay
  • cpe:2.3:a:webberzone:top_10:*:*:*:*:*:wordpress:*:* Versions up to 2.9.4 Vulnerable ·ajay

Remediation

  • Fix · CNA WebberZone Top 10 — Popular Posts (ajay) Fixed in 2.9.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-36761
  2. 2026-10-03 Alias added: GHSA-2xcx-834w-fp84

References

  • TI-2023-25556 WordPress Top 10 Plugin <= 3.3.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2023-11238 WordPress Top 10 – Popular posts plugin for WordPress plugin <= 3.2.3 - Broken Access Control vulnerability CVSS 3.1MEDIUM 4.3

Sources