PrestaShop autoupgrade module ZIP archives were vulnerable from CVE-2017-9841
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Impact We have identified that some autoupgrade module ZIP archives have been built with phpunit dev dependencies. PHPUnit contains a php script that would allow, on a webserver, an attacker to perform a RCE. This vulnerability impacts - phpunit before 4.8.28 and 5.x before 5.6.3 as reported in [CVE-2017-9841](https://nvd.nist.gov/vuln/detail/CVE-2017-9841) - phpunit >= 5.63 before 7.5.19 and 8.5.1 (this is a newly found vulnerability that is currently being submitted as a CVE after disclosure was provided to phpunit maintainers) You can read PrestaShop official statement about this vulnerability [here](https://build.prestashop.com/news/critical-security-vulnerability-in-prestashop-modules/). ### Patches In the [security patch](https://github.com/PrestaShop/autoupgrade/releases/tag/v4.10.1), we look for the unwanted vendor/phpunit folder and remove it if we find it. This allows users to fix the security issue when upgrading. ### Workarounds Users can also simply remove the unwanted vendor/phpunit folder. ### References https://nvd.nist.gov/vuln/detail/CVE-2017-9841 ### For more information If you have any questions or comments about this advisory, email us at [email protected]
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | prestashop/autoupgrade (Packagist) | 4.0.0 to before 4.10.1 | 4.10.1 | Patch available | GHSA-wqq8-mqj9-697f |
- prestashop/autoupgrade (Packagist) Vendor— Affected 4.0.0 to before 4.10.1 Fixed in 4.10.1 Patch available GHSA-wqq8-mqj9-697f
Remediation
- Fix · GHSA-wqq8-mqj9-697f prestashop/autoupgrade (Packagist) Fixed in 4.10.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-wqq8-mqj9-697f
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences