Read the docs
TI-2020-19408 Aliases GHSA-v73w-r9xg-7cr9

Use of insecure jQuery version in OctoberCMS

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact Passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. ### Patches Issue has been patched in Build 466 (v1.0.466) by applying the recommended patch from @jquery. ### Workarounds Apply https://github.com/octobercms/october/commit/5c7ba9fbe9f2b596b2f0e3436ee06b91b97e5892 to your installation manually if unable to upgrade to Build 466. ### References - https://github.com/jquery/jquery/security/advisories/GHSA-gxr4-xjj5-5px2 - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11022 - https://jquery.com/upgrade-guide/3.5/ ### For more information If you have any questions or comments about this advisory: * Email us at [[email protected]](mailto:[email protected]) & [[email protected]](mailto:[email protected]) ### Threat Assessment Assessed as Moderate by the @jquery team. ### Acknowledgements Thanks to @mrgswift for reporting the issue to the October CMS team.

Why it matters now

Fix Fixed october/october (Packagist): 1.0.466october/system (Packagist): 1.0.466

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—october/october (Packagist)1.0.319 to before 1.0.4661.0.466Patch availableGHSA-v73w-r9xg-7cr9
—october/system (Packagist)1.0.319 to before 1.0.4661.0.466Patch availableGHSA-v73w-r9xg-7cr9
  • october/october (Packagist) Vendor— Affected 1.0.319 to before 1.0.466 Fixed in 1.0.466 Patch available GHSA-v73w-r9xg-7cr9
  • october/system (Packagist) Vendor— Affected 1.0.319 to before 1.0.466 Fixed in 1.0.466 Patch available GHSA-v73w-r9xg-7cr9

Remediation

  • Fix · GHSA-v73w-r9xg-7cr9 october/october (Packagist) Fixed in 1.0.466 Advisory →
  • Fix · GHSA-v73w-r9xg-7cr9 october/system (Packagist) Fixed in 1.0.466 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-v73w-r9xg-7cr9

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences