Cross-Site Scripting in highcharts
Priority LOW 38CWE-79Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.
Summary
Versions of `highcharts` prior to 7.2.2 or 8.1.1 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize `href` values and does not restrict URL schemes, allowing attackers to execute arbitrary JavaScript in a victim's browser if they click the link.
Why it matters now
Fix Fixed highcharts (npm): 7.2.2, 8.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | highcharts (npm) | before 7.2.2 | 7.2.2 | Patch available | GHSA-gr4j-r575-g665 |
| — | highcharts (npm) | 8.0.0 to before 8.1.1 | 8.1.1 | Patch available | GHSA-gr4j-r575-g665 |
- highcharts (npm) Vendor— Affected before 7.2.2 Fixed in 7.2.2 Patch available GHSA-gr4j-r575-g665
- highcharts (npm) Vendor— Affected 8.0.0 to before 8.1.1 Fixed in 8.1.1 Patch available GHSA-gr4j-r575-g665
Remediation
- Fix · GHSA-gr4j-r575-g665 highcharts (npm) Fixed in 7.2.2 Advisory →
- Fix · GHSA-gr4j-r575-g665 highcharts (npm) Fixed in 8.1.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-gr4j-r575-g665
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences