Read the docs
TI-2020-19424 Aliases GHSA-6qqj-rx4w-r3cj

CSRF Vulnerability in jquery-ujs

Priority LOW 38CWE-352Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Tampering
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-352.

Summary

Versions 1.0.3 and earlier of jquery-ujs are vulnerable to an information leakage attack that may enable attackers to launch CSRF attacks, as it allows attackers to send CSRF tokens to external domains. When an attacker controls the href attribute of an anchor tag, or the action attribute of a form tag triggering a POST action, the attacker can set the href or action to " https://attacker.com". By prepending a space to the external domain, it causes jQuery to consider it a same origin request, resulting in the user's CSRF token being sent to the external domain. ## Recommendation Upgrade jquery-ujs to version 1.0.4 or later.

Why it matters now

Fix Fixed jquery-ujs (npm): 1.0.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—jquery-ujs (npm)before 1.0.41.0.4Patch availableGHSA-6qqj-rx4w-r3cj
  • jquery-ujs (npm) Vendor— Affected before 1.0.4 Fixed in 1.0.4 Patch available GHSA-6qqj-rx4w-r3cj

Remediation

  • Fix · GHSA-6qqj-rx4w-r3cj jquery-ujs (npm) Fixed in 1.0.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-6qqj-rx4w-r3cj

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences