Remote Memory Exposure in mongoose
Priority LOW 38CWE-201Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-201.
Summary
Versions of `mongoose` before 4.3.6, 3.8.39 are vulnerable to remote memory exposure. Trying to save a number to a field of type Buffer on the affected mongoose versions allocates a chunk of uninitialized memory and stores it in the database. ## Recommendation Update to version 4.3.6, 3.8.39 or later.
Why it matters now
Fix Fixed mongoose (npm): 3.8.39, 4.3.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | mongoose (npm) | 3.5.5 to before 3.8.39 | 3.8.39 | Patch available | GHSA-r5xw-q988-826m |
| — | mongoose (npm) | 4.0.0 to before 4.3.6 | 4.3.6 | Patch available | GHSA-r5xw-q988-826m |
- mongoose (npm) Vendor— Affected 3.5.5 to before 3.8.39 Fixed in 3.8.39 Patch available GHSA-r5xw-q988-826m
- mongoose (npm) Vendor— Affected 4.0.0 to before 4.3.6 Fixed in 4.3.6 Patch available GHSA-r5xw-q988-826m
Remediation
- Fix · GHSA-r5xw-q988-826m mongoose (npm) Fixed in 3.8.39 Advisory →
- Fix · GHSA-r5xw-q988-826m mongoose (npm) Fixed in 4.3.6 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-r5xw-q988-826m
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences