Read the docs
TI-2020-19471 Aliases GHSA-m852-866j-69j8

Malicious Package in eslint-config-airbnb-standard

Priority LOW 38CWE-506Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Code execution
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-506.

Summary

Version 2.0.0 of `eslint-config-airbnb-standard` was published with a bundled version of `eslint-scope` that was found to contain malicious code. This code would read the users `.npmrc` file and send it's contents to a remote server. ## Recommendation The best course of action if you found this package installed in your environment is to revoke all your npm tokens and use a different version of the module. You can find instructions on how to do that here. https://docs.npmjs.com/getting-started/working_with_tokens#how-to-revoke-tokens

Why it matters now

Fix Fixed eslint-config-airbnb-standard (npm): 2.1.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—eslint-config-airbnb-standard (npm)2.0.0 to before 2.1.02.1.0Patch availableGHSA-m852-866j-69j8
  • eslint-config-airbnb-standard (npm) Vendor— Affected 2.0.0 to before 2.1.0 Fixed in 2.1.0 Patch available GHSA-m852-866j-69j8

Remediation

  • Fix · GHSA-m852-866j-69j8 eslint-config-airbnb-standard (npm) Fixed in 2.1.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-m852-866j-69j8

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences