Improper Authorization in loopback
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-285.
Summary
Vulnerable versions of `loopback` may allow attackers to create Authentication Tokens on behalf of other users due to Improper Authorization. If the AccessToken model is publicly exposed, an attacker can create Authorization Tokens for any user as long as they know the target's `userId`. This will allow the attacker to access the user's data and their privileges. ## Recommendation For loopback 2.x, upgrade to version 2.40.0 or later For loopback 3.x, upgrade to version 3.22.0 or later
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | loopback (npm) | before 2.40.0 | 2.40.0 | Patch available | GHSA-8wgc-jjvv-cv6v |
| — | loopback (npm) | 3.0.0 to before 3.22.0 | 3.22.0 | Patch available | GHSA-8wgc-jjvv-cv6v |
- loopback (npm) Vendor— Affected before 2.40.0 Fixed in 2.40.0 Patch available GHSA-8wgc-jjvv-cv6v
- loopback (npm) Vendor— Affected 3.0.0 to before 3.22.0 Fixed in 3.22.0 Patch available GHSA-8wgc-jjvv-cv6v
Remediation
- Fix · GHSA-8wgc-jjvv-cv6v loopback (npm) Fixed in 2.40.0 Advisory →
- Fix · GHSA-8wgc-jjvv-cv6v loopback (npm) Fixed in 3.22.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-8wgc-jjvv-cv6v
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences