Arbitrary File Overwrite in decompress-zip
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
Vulnerable versions of `decompress-zip` are affected by the Zip-Slip vulnerability, an arbitrary file write vulnerability. The vulnerability occurs because `decompress-zip` does not verify that extracted files do not resolve to targets outside of the extraction root directory. ## Recommendation For `decompress-zip` 0.2.x upgrade to 0.2.2 or later. For `decompress-zip` 0.3.x upgrade to 0.3.2 or later.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | decompress-zip (npm) | before 0.2.2 | 0.2.2 | Patch available | GHSA-73v8-v6g4-vrpm |
| — | decompress-zip (npm) | 0.3.0 to before 0.3.2 | 0.3.2 | Patch available | GHSA-73v8-v6g4-vrpm |
- decompress-zip (npm) Vendor— Affected before 0.2.2 Fixed in 0.2.2 Patch available GHSA-73v8-v6g4-vrpm
- decompress-zip (npm) Vendor— Affected 0.3.0 to before 0.3.2 Fixed in 0.3.2 Patch available GHSA-73v8-v6g4-vrpm
Remediation
- Fix · GHSA-73v8-v6g4-vrpm decompress-zip (npm) Fixed in 0.2.2 Advisory →
- Fix · GHSA-73v8-v6g4-vrpm decompress-zip (npm) Fixed in 0.3.2 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-73v8-v6g4-vrpm
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences