Sensitive Data Exposure in loopback
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-200.
Summary
Versions of `loopback` prior to 3.26.0 (3.x) and 2.42.0 (2.x) are vulnerable to Sensitive Data Exposure. Invalid API requests to the login endpoint may return information about the first user in the database. This can be used alongside other attacks for credential theft. ## Recommendation If you're using `loopback` 3.x upgrade to version 3.26.0 or later. If you're using `loopback` 2.x upgrade to version 2.42.0 or later.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | loopback (npm) | before 2.42.0 | 2.42.0 | Patch available | GHSA-724c-6vrf-99rq |
| — | loopback (npm) | 3.0.0 to before 3.26.0 | 3.26.0 | Patch available | GHSA-724c-6vrf-99rq |
- loopback (npm) Vendor— Affected before 2.42.0 Fixed in 2.42.0 Patch available GHSA-724c-6vrf-99rq
- loopback (npm) Vendor— Affected 3.0.0 to before 3.26.0 Fixed in 3.26.0 Patch available GHSA-724c-6vrf-99rq
Remediation
- Fix · GHSA-724c-6vrf-99rq loopback (npm) Fixed in 2.42.0 Advisory →
- Fix · GHSA-724c-6vrf-99rq loopback (npm) Fixed in 3.26.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-724c-6vrf-99rq
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences