Denial of Service in @hapi/accept
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
Versions of `@hapi/accept` prior to 3.2.4 or 5.0.1 are vulnerable to Denial of Service. The Accept-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services. ## Recommendation Upgrade to version 3.2.4 or 5.0.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | @hapi/accept (npm) | 3.2.0 to before 3.2.4 | 3.2.4 | Patch available | GHSA-9vrw-m88g-w75q |
| — | @hapi/accept (npm) | 4.0.0 to before 5.0.1 | 5.0.1 | Patch available | GHSA-9vrw-m88g-w75q |
- @hapi/accept (npm) Vendor— Affected 3.2.0 to before 3.2.4 Fixed in 3.2.4 Patch available GHSA-9vrw-m88g-w75q
- @hapi/accept (npm) Vendor— Affected 4.0.0 to before 5.0.1 Fixed in 5.0.1 Patch available GHSA-9vrw-m88g-w75q
Remediation
- Fix · GHSA-9vrw-m88g-w75q @hapi/accept (npm) Fixed in 3.2.4 Advisory →
- Fix · GHSA-9vrw-m88g-w75q @hapi/accept (npm) Fixed in 5.0.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-9vrw-m88g-w75q
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences