Denial of Service in @hapi/ammo
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
Versions of `@hapi/ammo` prior to 3.1.2 or 5.0.1 are vulnerable to Denial of Service. The Range HTTP header parser has a vulnerability which will cause the function to throw a system error if the header is set to an invalid value. Because hapi is not expecting the function to ever throw, the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services. ## Recommendation Upgrade to version 3.1.2 or 5.0.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | @hapi/ammo (npm) | before 3.1.2 | 3.1.2 | Patch available | GHSA-gjph-xf5q-6mfq |
| — | @hapi/ammo (npm) | 4.0.0 to before 5.0.1 | 5.0.1 | Patch available | GHSA-gjph-xf5q-6mfq |
- @hapi/ammo (npm) Vendor— Affected before 3.1.2 Fixed in 3.1.2 Patch available GHSA-gjph-xf5q-6mfq
- @hapi/ammo (npm) Vendor— Affected 4.0.0 to before 5.0.1 Fixed in 5.0.1 Patch available GHSA-gjph-xf5q-6mfq
Remediation
- Fix · GHSA-gjph-xf5q-6mfq @hapi/ammo (npm) Fixed in 3.1.2 Advisory →
- Fix · GHSA-gjph-xf5q-6mfq @hapi/ammo (npm) Fixed in 5.0.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-gjph-xf5q-6mfq
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences