Denial of Service in @hapi/content
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
Versions of `@hapi/content` prior to 4.1.1 and 5.0.1 are vulnerable to Denial of Service. The Content-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services. ## Recommendation Upgrade to version 5.0.2. Versions 4.1.1 and 5.0.1 are fixed but only available for direct download through the repository.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | @hapi/content (npm) | before 5.0.2 | 5.0.2 | Patch available | GHSA-3wqh-h42r-x8fq |
- @hapi/content (npm) Vendor— Affected before 5.0.2 Fixed in 5.0.2 Patch available GHSA-3wqh-h42r-x8fq
Remediation
- Fix · GHSA-3wqh-h42r-x8fq @hapi/content (npm) Fixed in 5.0.2 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-3wqh-h42r-x8fq
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences