Denial of Service in @hapi/hapi
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
Versions of `@hapi/hapi` prior to 18.4.1 or 19.1.1 are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services. ## Recommendation Upgrade to versions 18.4.1, 19.1.1 or later.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | @hapi/hapi (npm) | before 18.4.1 | 18.4.1 | Patch available | GHSA-23vw-mhv5-grv5 |
| — | @hapi/hapi (npm) | 19.0.0 to before 19.1.1 | 19.1.1 | Patch available | GHSA-23vw-mhv5-grv5 |
- @hapi/hapi (npm) Vendor— Affected before 18.4.1 Fixed in 18.4.1 Patch available GHSA-23vw-mhv5-grv5
- @hapi/hapi (npm) Vendor— Affected 19.0.0 to before 19.1.1 Fixed in 19.1.1 Patch available GHSA-23vw-mhv5-grv5
Remediation
- Fix · GHSA-23vw-mhv5-grv5 @hapi/hapi (npm) Fixed in 18.4.1 Advisory →
- Fix · GHSA-23vw-mhv5-grv5 @hapi/hapi (npm) Fixed in 19.1.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-23vw-mhv5-grv5
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences