Denial of Service in @commercial/hapi
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
Affected versions of `@commercial/hapi` are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services. ## Recommendation Upgrade to versions 16.8.2, 17.9.2, 18.4.1, 19.1.1 or later.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | @commercial/hapi (npm) | before 16.8.2 | 16.8.2 | Patch available | GHSA-66mv-xh68-h6v2 |
| — | @commercial/hapi (npm) | 17.0.0 to before 17.9.2 | 17.9.2 | Patch available | GHSA-66mv-xh68-h6v2 |
| — | @commercial/hapi (npm) | 18.0.0 to before 18.4.1 | 18.4.1 | Patch available | GHSA-66mv-xh68-h6v2 |
| — | @commercial/hapi (npm) | 19.0.0 to before 19.1.1 | 19.1.1 | Patch available | GHSA-66mv-xh68-h6v2 |
- @commercial/hapi (npm) Vendor— Affected before 16.8.2 Fixed in 16.8.2 Patch available GHSA-66mv-xh68-h6v2
- @commercial/hapi (npm) Vendor— Affected 17.0.0 to before 17.9.2 Fixed in 17.9.2 Patch available GHSA-66mv-xh68-h6v2
- @commercial/hapi (npm) Vendor— Affected 18.0.0 to before 18.4.1 Fixed in 18.4.1 Patch available GHSA-66mv-xh68-h6v2
- @commercial/hapi (npm) Vendor— Affected 19.0.0 to before 19.1.1 Fixed in 19.1.1 Patch available GHSA-66mv-xh68-h6v2
Remediation
- Fix · GHSA-66mv-xh68-h6v2 @commercial/hapi (npm) Fixed in 16.8.2 Advisory →
- Fix · GHSA-66mv-xh68-h6v2 @commercial/hapi (npm) Fixed in 17.9.2 Advisory →
- Fix · GHSA-66mv-xh68-h6v2 @commercial/hapi (npm) Fixed in 18.4.1 Advisory →
- Fix · GHSA-66mv-xh68-h6v2 @commercial/hapi (npm) Fixed in 19.1.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-66mv-xh68-h6v2
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences