Arbitrary Code Execution in require-node
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-78.
Summary
Versions of `require-node` prior to 1.3.4 for 1.x and 2.0.4 for 2.x are vulnerable to Arbitrary Code Execution. The package fails to sanitize requests to the `require-node` endpoint, allowing attackers to execute arbitrary code in the server through the injection of OS commands in the request body. ## Recommendation - If you are using 1.x, upgrade to version 1.3.4 or later. - If you are using 2.x, upgrade to version 2.0.4 or later.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | require-node (npm) | before 1.3.4 | 1.3.4 | Patch available | GHSA-8j6j-4h2c-c65p |
| — | require-node (npm) | 2.0.0 to before 2.0.4 | 2.0.4 | Patch available | GHSA-8j6j-4h2c-c65p |
- require-node (npm) Vendor— Affected before 1.3.4 Fixed in 1.3.4 Patch available GHSA-8j6j-4h2c-c65p
- require-node (npm) Vendor— Affected 2.0.0 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-8j6j-4h2c-c65p
Remediation
- Fix · GHSA-8j6j-4h2c-c65p require-node (npm) Fixed in 1.3.4 Advisory →
- Fix · GHSA-8j6j-4h2c-c65p require-node (npm) Fixed in 2.0.4 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-8j6j-4h2c-c65p
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences